Download

There are a number of versions of Seagull available for download, pick the one that best suits your needs. Following the links will take you to a SourceForge mirrors page, simply choose the geographically nearest location to where you are to be taken to the appropriate mirror. Detailed install instructions are available at the wiki.

Stable

You'll want a release from the stable branch if you're using the framework for customer sites or are in a similar situation where reliability and stability are important.

  • [5,1 MB] seagull-1.0.4 (includes PEAR libs, EN language only, MySQL data only, and some of the BSD modules)
  • [309 kb] API docs

A full list of historical releases is also available.

Download Package

The download package provides the smallest amount of downloadable code and just the core framework components. Currently it's distributed with PEAR and FCKeditor wysiwyg libraries. Without said libraries the core Seagull code is just 504kb, we're working on further extracting the dependencies. Also in the near future the user module will be extracted and installable on demand like the other modules.

Full Package

The full package is available from svn, minus a few administrative scripts and non-essential examples. If you're a developer wanting to run the test suite, or you want to try the many modules/applications provided with the framework, this package is your best bet.

PEAR package

The PEAR package is recommended for experienced developers and offers the advantage that it fully integrates Seagull with your PEAR repository, and takes advantage of any libs you may already have installed. Obviously when you choose this option you can upgrade your PEAR libs independently of when new Seagull releases come out. The PEAR installer also resolves all package dependencies automatically.

Best Results

Please consider the following versions for your database and webserver software to get the best results from Seagull:

  • PHP: PHP 4.3.0 is the minimum, recent versions work fine with PHP 5.3.x and 5.4.x.  Avoid anything in the PHP 5.0.x series
  • MySQL: MySQL 5.5.x is recommended. Older versions support 3.23.x.
  • Apache: Seagull works fine with 1.3.x and 2.x series of Apache

At a Glance

Sponsors

Login

Username Password

Not Registered?
Forgot Your Password

*denotes required field

Community

 
Seagull PHP Framework Seagull PHP Framework

Sponsored by

The Seagull project is sponsored by Seagull Systems, see the range of products offered.

Readers